Intermittent dashboard load failures

Incident Report for Orb

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 19:50 UTC

Identified

We've implemented a fix and are working on rolling it out.
Posted Nov 14, 2025 - 19:31 UTC

Investigating

We are currently investigating intermittent webapp load failures for some customers. API, ingestion, and invoicing are unaffected.
Posted Nov 14, 2025 - 19:07 UTC