Invoicing delays
Incident Report for Orb
Resolved
This incident has been resolved.
Posted Sep 16, 2024 - 22:12 UTC
Monitoring
We have identified delays in issuing invoices since around 16:00 UTC 9/16/2024.

A fix has been deployed, and we expect to fully recover within an hour as asynchronous processing catches up.
Posted Sep 16, 2024 - 21:15 UTC
This incident affected: Invoicing.